Tag: bash_profile

Run a PHP script from the command line with MAMP

Posted by – August 8, 2013

我在 Mac 上開發 PHP 一直是用 MAMP 這個好用的 App。不過如果碰到需要在 Terminal 下以指令方式執行 PHP 程式就有點麻煩。

MAMP 裡的 php 路徑頗長.... 像這樣...

/Applications/MAMP/bin/php/php5.3.6/bin/php -v # 查詢 PHP 版本

所以還是來修改一下 ~/.bash_profile 吧。如果沒有這個檔案,自己建一個。

在裡面加入這一行…

export PATH=/Applications/MAMP/bin/php/php5.3.6/bin/:$PATH

存檔後離開。

在 Terminal 下輸入

source ~/.bash_profile

會重讀設定檔,然後剛才的修改就生效了。這樣以後要執行 PHP script 直接輸入 php 就可以了,方便許多。

Install Python 3 on Mac OS X

Posted by – June 5, 2013

雖然我大部份時間都在和 PHP 奮戰,不過我對 PythonRuby 這些新一代的語言也很有興趣。

用過 Python 都知道這個可愛的語言有兩派大分支.... 2.x 版與 3.x 版。由於第三版有許多變動,導致與第二版不相容,這在程式碼的移稙上造成頗大的困擾。因此即使第三版已經釋出多年,仍有大量第二版的使用者。

至於我這個 Python 菜菜子是比較傾向直接學習第三版的。不過 Mac OS X 內建的第二版,我想更新到第三版。

在 Mac OS X 上更新 Python 是很容易的,只要到官網的下載頁面下載對應 Mac OS 的 Installer ,依畫面指示安裝即可。

Python Installer on Mac

安裝完後在 Terminal 下執行 python 卻還是會看到 Python 2.x 的訊息....

$ python
Python 2.7.2 (default, Oct 11 2012, 20:14:37)
[GCC 4.2.1 Compatible Apple Clang 4.0 (tags/Apple/clang-418.0.60)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>>

事實新安裝的版本路徑與系統內建的不同,並不會覆蓋,形成新舊版並存的現象。要用第三版要輸入 python3。

$ python3
Python 3.3.2 (v3.3.2:d047928ae3f6, May 13 2013, 13:52:24)
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>>

若是覺得這樣麻煩的話,可以修改設定。

vim ~/.bash_profile

加上一行設定。

alias python="python3"

存檔後輸入 python 就會直接進入新版囉。